Beatport Music Store

PLEASE REVIEW THE EXISTING REQUESTS FOR FEATURES AND BUGS BEFORE CREATING A FORUM POST. VOTES ARE THE BEST WAY TO GET FEATURE REQUESTS AND BUGS ATTENTION.

How can we improve Beatport Music Store?

You've used all your votes and won't be able to post a new idea, but you can still search and comment on existing ideas.

There are two ways to get more votes:

  • When an admin closes an idea you've voted on, you'll get your votes back from that idea.
  • You can remove your votes from an open idea you support.
  • To see ideas you have already voted on, select the "My feedback" filter and select "My open ideas".
(thinking…)

Enter your idea and we'll search to see if someone has already suggested it.

If a similar idea already exists, you can support and comment on it.

If it doesn't exist, you can post your idea so others can support it.

Enter your idea and we'll search to see if someone has already suggested it.

  • Hot ideas
  • Top ideas
  • New ideas
  • My feedback
  1. **Speed/Performance Too Slow & Timeouts**

    Play buttons in track lists doesn't work anymore, beachball all the time. Firefox runs just fine, but when skipping through a track you hear sound artefacts

    73 votes
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    43 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  2. 7 votes
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    5 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  3. Problem with section My Beatport!

    I don't see new tracks in My Beatport section, there wrote: YOU'RE NOT FOLLOWING ANYONE YET!
    But i have many following !

    6 votes
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    2 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  4. Stutter/crackling in preview player when using Microsoft Edge

    There's some annoying stutter/crackling in preview player stutter/crackling when using Microsoft Edge. This has been the case for quite some time and happens with the latest version too:
    Microsoft Edge 40.15063.0.0
    Microsoft EdgeHTML 15.15063

    It may be a bug in Edge but it may also be a problem in your code.

    4 votes
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  5. ***Played Track Indicator***

    This issue was closed on March 23, 2015, but a replay icon does not show up anywhere a played track appears under a unique account login.

    This is a critical feature for those of us who trawl through the thousands of archived and recently added tracks. It can mean the difference between using Beatport or not.

    3 votes
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  6. **Play All not Playing All for Filters Applied**

    Let the "play all" actually play the selected subcontext. When I set a bpm range, it doesn't isolate to just the bpm range. This makes it worthless, and I still have to click through each song individually, while what I selected in the pull-downs is disregarded.

    2 votes
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Open for Discussion & Votes  ·  1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  7. Accurate Tracks amount in Carts

    My carts do not show accurate numbers of tracks, for example, my cart says I have 16 tracks when I have 10. Fix please. (I have tried refreshing and re-visiting)

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  8. 1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  9. I have just uploaded two mixes and they doesn't play at all!

    I am always uploading my mixes on 320kbps. I don't know where is the problem. When I press play the mix does not play. This is happening only with my two last mixes I've just uploaded. Please fix this issue for me! Thank you!

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  10. Add to cart button keeps spinning if a track is already in the cart.

    On an album page / artist page. Add a track to a cart. The spinning circle on the button is displayed and a track is added to a cart. Now press the button again on the same track. The button is again displayed and keeps spinning infinitely.

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  11. Don't play tracks in playlist when added to carts

    example: I add a track from my playlist to a cart and it starts playing. Stop that please, or have a toggle option, I can play it by clicking anywhere else on the track, adding to a cart shouldn't be a play button.

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  12. Video preview / place holder

    Video previews don't show - just a grey space

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  13. Web service dosn't work proporty in Iceweasel

    I've used Debian 8 with Iceweasel browser. Web service doesn't work property, dropdown menu in username doesn't show, download is impossible either.

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  14. *** Login Hover Has Issues ***

    Hovering on the login/sign-up button to bring up the login modal is very annoying to use. At any time if you are not hovering on the modal it disappears!!!!! This even happens when selecting my username from the autofill suggestion on the username input; as soon as I hovered over that the modal disappeared. The validation error messaging is in a bad spot or at least behaves poorly; when a validation error message is displayed, setting focus to any input removes the error message causing the the height to shrink and if the mouse cursor happens to be at the…

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  15. just here to report a bug: the shopping cart creates duplicate items,then playing both at the same time

    just here to report a bug: the shopping cart creates duplicate items,then playing both at the same time. Also when I remove tracks it completely rearranges the sorting order,pretty much randomizes

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    1 comment  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  16. BPM filter is ignored if only min or max is defined

    I am not certain if this is a bug, but it definitely doesn't feel like a function either. The functionality of the BPM filter makes it feel like it is not working, thus there is at least one bug report already that fails to fully describe what is happening. This is my explanation of what seems to be the problem.

    BPM filter in browsing works only if both min and max values are given. Since most music within a genre, release or artist falls in between a certain range, I would argue that searches with 'less or equal than' and…

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  17. Genres menu doesn't stay visible on small desktop viewport

    In the smaller of the two responsive desktop viewports (not mobile nor the full desktop view) the Genres menu shows up when hovering over the Genres button, but disappears when moving the cursor slowly down towards the menu area. The bug is reliably reproducable on Safari 10.0.1.

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  18. Album Art Missing / Reverting to default Beatport image

    I can see the album art before purchasing, but after I download a track (AIFF format), the thumbnail in Finder (Mac) changes to an image of the track's waveform. When going back to the track, or release page on Beatport, the album art reverts to a default placeholder image preventing me from trying to save a copy manually.

    Also, other release images appear heavily pixelated and going to their respective pages presents the same placeholder image and not the actual album art. This appears to happen only immediately after making a purchase, but this has happened the last two times…

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    5 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  19. Incorrect cart amounts (money)

    The cart gives amounts like amount before tax 024.63 and 029.80 for total amount. I guess it just adds that unnecessary zero before the amount.

    1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
  20. 1 vote
    Vote
    Sign in
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    0 comments  ·  Bugs  ·  Flag idea as inappropriate…  ·  Admin →
← Previous 1
  • Don't see your idea?

Beatport Music Store

Feedback and Knowledge Base